Solana getSignatureStatuses and getSignaturesForAddress Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 18:05 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 17:34 UTC

Investigating

We are currently investigating an issue with our infrastructure provider, which may result in elevated error rates or latency for the getSignatureStatuses and getSignaturesForAddress methods.
Posted Jun 24, 2026 - 17:23 UTC
This incident affected: Solana.