Degraded performance on all networks

Incident Report for Alchemy

Resolved

Seeing recovery on all services and will be continuing to monitor.
Posted Jan 25, 2023 - 20:43 UTC

Investigating

We are currently investigating this issue.
Posted Jan 25, 2023 - 20:28 UTC