Rinkeby network stopped producing new blocks as of 3:05pm EST
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Aug 26, 2022 - 19:24 UTC
Investigating
We're monitoring this situation and will update when the network is back up
Posted Aug 26, 2022 - 19:22 UTC