CrossFi mainnet & testnet stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 11:07 UTC

Identified

We are currently investigating CrossFi stall. Preliminary observations suggest this may be a network-wide incident.
Posted Jan 02, 2026 - 13:18 UTC
This incident affected: CrossFi.