Unichain Mainnet - safe/finalized head stalled in use1

Incident Report for Alchemy

Resolved

A subset of nodes serving Unichain Mainnet in our US East (use1) region experienced stalled safe/finalized block tracking, causing delayed safe/finalized block data for requests routed through that region. The latest block head and overall API serving were unaffected throughout and no elevated error rates were observed.

We performed a rolling restart of the affected nodes, which resolved the issue. Safe/finalized data is now current and within normal lag across the region.

This incident is resolved!
Posted Aug 24, 2026 - 18:37 UTC

Investigating

We are investigating reports of delayed safe and finalized block tag data on Unichain Mainnet for requests routed through our US East (use1) region.

The latest block head and overall API serving are healthy and unaffected.

Applications relying on safe/finalized tags (e.g. via eth_getBlockByNumber, eth_getLogs, eth_call) in this region may receive outdated block data. We are actively investigating and will provide updates as we have them!
Posted Aug 24, 2026 - 12:23 UTC
This incident affected: Unichain.