Elevated latency in USE1 Region

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 15:24 UTC

Update

This incident has been resolved.
Posted Sep 23, 2025 - 15:23 UTC

Monitoring

We are working with the Cloudflare team and have observed improvements in latency within the USE1 region. Our team continues to actively monitor the situation.
Posted Sep 23, 2025 - 10:14 UTC

Investigating

We are investigating increased latency in the USE1 region and are actively coordinating with the Cloudflare team to resolve the issue.
Posted Sep 23, 2025 - 09:56 UTC