BNB Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

Our team has implemented a number of mitigations and we've seen performance metrics recover!
Posted Oct 09, 2025 - 20:24 UTC

Update

We are currently investigating occasional errors on BNB Chain. Customers may experience degraded performance.
Posted Oct 09, 2025 - 09:42 UTC

Investigating

We are currently investigating this issue.
Posted Oct 09, 2025 - 09:41 UTC
This incident affected: BNB Smart Chain.