[Network-Wide] Rise Testnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 07:41 UTC

Investigating

We are currently investigating degraded performance on Rise Testnet. Customers might experience elevated 5xx error rates and latency.
Posted Apr 01, 2026 - 15:16 UTC
This incident affected: Rise.