[Network-Wide] Abstract Mainnet Safe Head Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 04:02 UTC

Investigating

We are investigating a network-wide stall affecting safe and finalized blocks on Abstract Mainnet.
Posted Jul 15, 2026 - 23:09 UTC
This incident affected: Abstract.