New User Signups Temporarily Unavailable

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 20:45 UTC

Investigating

We are currently experiencing an issue preventing new users from creating Alchemy accounts. Multi-Factor Verification for signups is failing due to a 3rd party service disruption.

Existing customer accounts and API traffic are not impacted!
Posted Feb 12, 2026 - 18:57 UTC