Investigating - Cronos Testnet Degraded Performance

Incident Report for Alchemy

Identified

A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 19:27 UTC

Investigating

We're investigating elevated errors on Cronos Testnet. We appreciate your patience while our team is actively working to restore service.
Posted May 05, 2026 - 14:04 UTC
This incident affects: Cronos.