Ropsten network issue
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Sep 18, 2021 - 11:20 PDT
Investigating
We are currently investigating this issue.
Posted Sep 18, 2021 - 08:26 PDT
This incident affected: Ropsten (JSON-RPC Request API, Websockets API).