Unichain Sepolia network issues

Incident Report for Alchemy

Resolved

This incident has been resolved and nodes are indexing again!
Posted Mar 03, 2025 - 22:27 UTC

Investigating

We are aware that the Unichain Sepolia testnet is currently stalled. This is a network-wide issue affecting all providers, not specific to Alchemy.

We are actively monitoring the situation and will provide updates as more information becomes available!

Thank you for your patience!
Posted Mar 03, 2025 - 22:24 UTC
This incident affected: Unichain.