Elevated Latency and Increased Timeouts on Arbitrum Mainnet in USW

Incident Report for Alchemy

Resolved

This incident has been resolved and traffic is re-enabled for the region.
Posted Sep 27, 2025 - 11:37 UTC

Monitoring

We have pushed a change and are continuing to monitor performance.
Posted Sep 27, 2025 - 10:28 UTC

Identified

We are continuing to investigate this issue.
Posted Sep 26, 2025 - 22:35 UTC

Update

We are routing traffic away from the affected region while we work on a fix.
Posted Sep 26, 2025 - 21:58 UTC

Investigating

We are currently investigating degraded performance in one region, causing elevated latencies and timeouts.
Posted Sep 26, 2025 - 21:43 UTC
This incident affected: Arbitrum and US West.