Degraded Performance on Sei Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 14:22 UTC

Monitoring

A fix has been applied and we are seeing reduction in error rates. We will continue to monitor and confirm full resolution.
Posted Mar 22, 2026 - 09:10 UTC

Investigating

We are currently investigating degraded performance on Sei Mainnet. Customers might experience elevated error rates and latency. We will share more updates as we have them.
Posted Mar 22, 2026 - 08:40 UTC
This incident affected: SEI.