Elevated 500s Across Multiple Networks

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 00:13 UTC

Monitoring

A fix has been implemented, and we’re actively monitoring the situation to ensure stability.
Posted Feb 18, 2026 - 00:13 UTC

Identified

The issue has been identified, and we’re currently implementing a fix.
Posted Feb 17, 2026 - 23:46 UTC

Investigating

We’re currently investigating an issue causing elevated internal server errors across multiple networks. We’ll provide updates as soon as we have more information.
Posted Feb 17, 2026 - 23:43 UTC