Blast Sepolia eth_call issues

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 15:12 UTC

Investigating

Following the Pectra upgrade, nodes on Blast Sepolia have been experiencing issues with eth_call. The testnet has been down, with block production also impacted.

This is a network wide incident and our team is actively investigating the root cause! Further updates will be provided as soon as we have more details!
Posted Mar 05, 2025 - 21:07 UTC
This incident affected: Blast.