Investigating - Degraded Data API Endpoints

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 18:18 UTC

Monitoring

We're aware of elevated error rates and increased latency affecting some Data API endpoints, especially Portfolio, Token and Balances. We have shipped a fix and are monitoring the situation.
Posted Jul 03, 2026 - 09:30 UTC