Polygon zkEVM network-wide stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 12:17 UTC

Investigating

We’re currently seeing a network-wide stall, with the last block mined at 27515138
Posted Nov 26, 2025 - 18:32 UTC
This incident affected: Polygon zkEVM.