Arbitrum Sepolia safe/finalized head stalled

Incident Report for Alchemy

Resolved

The Arbitrum team implemented the necessary fixes, and the incident has been resolved.
Posted Oct 15, 2025 - 07:00 UTC

Investigating

The Arbitrum Sepolia chain’s finalized and safe heads are currently stalled due to a broken binary release following the Fusaka upgrade. This issue is affecting all providers chain-wide.
Posted Oct 14, 2025 - 09:17 UTC
This incident affected: Arbitrum.