Sei Mainnet - Elevated Latency and Error Rates

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 07, 2026 - 08:30 UTC

Monitoring

We've applied mitigations that have significantly reduced the error rate on SEI Mainnet. We're continuing to monitor while working on a longer-term fix with the SEI team to fully eliminate the remaining errors during periods of high chain activity.
Posted May 05, 2026 - 14:24 UTC

Update

SEI latency and error rates are continuing and impacting all methods. We are working with the SEI team and are actively continuing the investigation.
Posted May 02, 2026 - 18:40 UTC

Investigating

Elevated Latency & Error Rates on eth_getTransactionReceipt, debug_traceTransaction, and debug_traceBlock methods. We are currently investigating this issue.
Posted May 02, 2026 - 16:25 UTC
This incident affected: SEI.