BNB Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 04:58 UTC

Update

We’ve implemented several mitigations that have significantly improved BNB Chain stability, though the issue is not yet fully resolved. The root cause stems from instability in the Erigon archive node client - a known issue affecting multiple node operators.

Our team is actively collaborating with the Erigon maintainers and has deployed configuration changes aligned with their recommendations. In parallel, we’re spinning up additional Geth full nodes with full transaction history and scaling Erigon instances to better balance load and improve overall reliability.

We continue to monitor performance closely and will share further updates as we make progress.
Posted Oct 13, 2025 - 14:23 UTC

Investigating

We are currently investigating occasional errors on BNB Chain. Customers may experience degraded performance.
Posted Oct 10, 2025 - 07:49 UTC
This incident affected: BNB Smart Chain.