Alchemy Dashboard experiencing gateway timeouts
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 15:28 UTC
Investigating
We're seeing more reports of Alchemy dashboard being down or slow for some users. We're actively investigating this, and will update as soon as a fix is in place.

Note: All API usage remains fully operational.
Posted Mar 11, 2024 - 04:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2024 - 16:08 UTC
Investigating
We are currently investigating an issue with Alchemy dashboard not loading and resulting in gateway timeout errors for users. We will update our status page as soon as this is resolved.

All API usage remains fully operational.
Posted Mar 10, 2024 - 15:52 UTC
This incident affected: Website Status.