X-Layer Testnet stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 17:10 UTC

Identified

The X-Layer team is currently conducting network-level load testing. This is causing intermittent performance issues across multiple RPC nodes. We are in direct communication with their team to mitigate the impact.
Posted Mar 25, 2026 - 09:54 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2026 - 09:39 UTC
This incident affected: X-Layer.