ZKsync Era & Abstract Mainnet - Finalized Tag Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 16:27 UTC

Investigating

We are currently investigating an issue where the finalized block tag on ZKsync Era and Abstract mainnet has stopped progressing. This appears to be an upstream network issue. We are monitoring for resolution and will provide updates as the situation develops.
Posted Mar 20, 2026 - 14:41 UTC
This incident affected: Abstract and ZKsync.