[Network-Wide] Arbitrum Sepolia Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 21:50 UTC

Identified

A bug in Nitro software caused a block divergence on Arbitrum Sepolia, leading to block production being halted as a precaution. This issue is affecting all Arbitrum Orbit rollups that depend on the same Nitro version.
Other Impacted networks:
Anime Sepolia
ApeChain Curtis
Mind Testnet
Edge Testnet
EARNM Testnet
Additional Arbitrum-based rollups may also be affected

No user funds are at risk.

The team is actively working on an infrastructure update and a new Nitro release to restore block production.
Posted Mar 23, 2026 - 20:11 UTC

Update

We are continuing to investigate this issue.
Posted Mar 23, 2026 - 18:09 UTC

Investigating

Arbitrum Sepolia is currently experiencing a network-wide stall. All services that rely on network progress are impacted. We are working closely with the Arbitrum team to resolve this as quickly as possible
Posted Mar 23, 2026 - 16:45 UTC
This incident affected: Arbitrum.