Pause on new account signups via Alchemy.com

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 17, 2022 - 03:24 UTC

Investigating

We are currently investigating this issue.
Posted Oct 17, 2022 - 03:10 UTC