Botanix Testnet RPC Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 13:09 UTC

Investigating

We are currently investigating degraded performance affecting Botanix Testnet. Our nodes are stalled at block 3,955,262 and not producing new blocks.

This issue is network-wide and affects all Botanix Testnet RPC traffic. We are actively coordinating with the Botanix team and will provide updates as the situation develops.
Posted Apr 07, 2026 - 12:28 UTC
This incident affected: Botanix.