Stable Mainnet - Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 12:00 UTC

Update

Full nodes (at head) are seeing good traffic and stable performance!

Archive nodes are still being worked on - ETA 1 hour if things go well. We'll continue to provide updates as we make progress!
Posted Jul 23, 2026 - 13:20 UTC

Update

The team is aware Stable Mainnet nodes are down, actively investigating and recovering the nodes via snapshots.
Posted Jul 23, 2026 - 09:36 UTC

Identified

A subset of requests on Stable Mainnet are experiencing degraded performance.
Posted Jul 23, 2026 - 09:34 UTC
This incident affected: Stable.