Elevated Latency for Robinhood Mainnet

Incident Report for Alchemy

Resolved

Latency has returned to normal for Robinhood Mainnet. We will continue to monitor the service.
Posted Aug 22, 2026 - 22:43 UTC

Update

Our team is continuing to investigate elevated latency affecting Robinhood Mainnet requests.
Posted Aug 22, 2026 - 22:05 UTC

Investigating

We are investigating elevated latency affecting Robinhood Mainnet requests. Our team is working to restore normal performance.
Posted Aug 22, 2026 - 21:33 UTC
This incident affected: Robinhood.