[Network-Wide] opBNB Testnet Stalled

Incident Report for Alchemy

Resolved

Preliminary observation suggests this may have been a network-wide stall. The network has resumed and is producing blocks.
Posted Apr 09, 2026 - 13:29 UTC

Investigating

We are currently investigating this issue.
Posted Apr 09, 2026 - 10:26 UTC
This incident affected: opBNB.