Degraded Performance on Scroll Mainnet
Incident Report for Alchemy
Resolved
The incident has been resolved.
Posted Oct 22, 2024 - 10:04 UTC
Investigating
Increased activity on Scroll is causing delays in batch commitment and finalization. This a network-wide issue.
Posted Oct 22, 2024 - 08:51 UTC
This incident affected: Scroll.