This is resolved. Base Mainnet's Safe head has caught up and data batching to Ethereum L1 is back to normal. Block production was unaffected throughout. See the Base status page for their full update: https://status.base.org/incidents/j6y12tshwkcg
Posted Jul 28, 2026 - 15:33 UTC
Identified
This is a network-wide issue on Base Mainnet, not specific to Alchemy. The Safe head is delayed because data batching to Ethereum L1 is lagging. New block production on Base Mainnet is progressing normally, and requests against the latest block are unaffected. Only queries and workflows that depend on the safe or finalized block tag will see staleness. Refer to the Base status page for the latest updates: https://status.base.org/incidents/j6y12tshwkcg
Posted Jul 28, 2026 - 13:32 UTC
Investigating
We are investigating a network-wide stall affecting safe and finalized blocks on Base Mainnet.