Polygon Hardfork Bug
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 23:29 UTC
Update
We've been working with the Polygon team to ensure we're always on the latest / best release! There was one more issue introduced in the last few releases that our on-call team caught and resolved late Sunday night (with help from the Polygon team).

We are currently on v0.3.5-beta, which is the result of us working with the Polygon team to hot-fix significant issues. Please don't hesitate to reach out if you see anything else!
Posted Feb 15, 2023 - 06:49 UTC
Update
We're still working on a root cause and fix alongside the Polygon eng team, but continue to focus both solving the underlying node issues, and mitigating the impact. Our eng team has been all hands on deck, working late into the night to diagnose issues with the core Polygon nodes that cropped up since the hard fork earlier this week.

Appreciate your patience as we work to help the Polygon team resolve this issue!
Posted Jan 20, 2023 - 18:40 UTC
Identified
As part of the recent Polygon hardfork on January 17, the MATIC Bor client released version v0.3.3, introducing a few node-level client bugs. Alchemy's Polygon nodes are largely healthy but may occasionally experience degraded performance in the form of 503 responses. We are actively working to resolve these issues and coordinating with the Polygon team for them to publish a hotfix via node version v0.3.4.
Posted Jan 19, 2023 - 18:49 UTC
This incident affected: Polygon PoS Mainnet (JSON-RPC Request API, Websockets API, Archive, NFT API, Notify API).