Polygon ZkEVM - Degraded Performance
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted May 28, 2024 - 18:43 UTC
Update
This is a network-wide issue.
Posted May 28, 2024 - 18:03 UTC
Investigating
We are currently investigating the issue.
Posted May 28, 2024 - 17:46 UTC